UI slowness and timeouts

Incident Report for VUSION Cloud

Resolved

All activity is now back to normal. All failed operations have been successfully replayed, and the platform is now fully available again.
Thank you for your patience and understanding.
Posted Apr 29, 2026 - 12:36 UTC

Monitoring

Manual scaling has been successfully performed. Failed operations are being replayed, and performance is back to expected levels.
We will be actively monitoring the situation in the coming hours.
Posted Apr 29, 2026 - 10:49 UTC

Identified

The issue has been identified as a failed automatic scaling. Resources have been manually scaled out to handle the current load.
Posted Apr 29, 2026 - 10:46 UTC

Investigating

Dear VusionCloud users,

We are experiencing high resource usage and scalability issues. We are currently investigating hte issue.
Users may experience Gateway Timeout errors, or slowness in the user interface. No specific action is required on the users' side.

Our engineers are actively working on this issue.

THank you for your understanding.
Posted Apr 29, 2026 - 10:11 UTC
This incident affected: Europe (VUSION Manager - Europe, VUSION Cloud API - Europe).