[Europe and US] Matching and Item data integration failures and delays

Incident Report for VUSION Cloud

Resolved

Dear customers,

Metrics show full recovery and data has been processed. Transmissions are being processed as expected.

We will work with Microsoft to avoid the risk of such incident and we will share the post-mortem, with necessary details.

We would like to thank you for your understanding during this incident.
Posted May 13, 2025 - 06:18 UTC

Update

Dear customers,

The change has been rolled out and our metrics are showing that the issue does not occur anymore.

Additionally, our engineers are actively replaying all the matchings and item integrations that were received by the system but not executed during the disruption period. This ensures that all pending data is processed correctly without any loss.

We will continue to monitor the situation closely and keep you updated.

Thank you for your understanding.
Posted May 13, 2025 - 04:26 UTC

Monitoring

Dear customers,

Our engineers have found a workaround and they are rolling it out across instances. Our metrics show recovery after the change is applied.

We will keep you informed as the workaround is deployed and data processed.

Thank you for your understanding.
Posted May 13, 2025 - 03:54 UTC

Identified

Dear customers,

We have identified a processing issue, for items data integration as well as matchings, that is impacting most customers in Europe and US environments.
Our analysis has traced it to a change on Microsoft Azure. Our engineers have engaged with Azure support and are working on finding a workaround.

No data has been lost. Once we recover operations, we will be able to process data.

We understand that such situations have major impact in your stores' operations and we are working to resolve as soon as possible. We will keep you informed as the situation progresses.

Thank you for your understanding.
Posted May 13, 2025 - 01:53 UTC
This incident affected: Europe (VUSION Cloud API - Europe) and Americas (VUSION Cloud API - Americas).